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CAPÍTULO 1 
 

INTRODUCCIÓN A OILFIELD MANAGER 
 
 

OFM es un poderoso software de análisis de información del pozo y del 

reservorio, es una valiosa herramienta de producción sobre su escritorio. 

Incorpora técnicas de ingeniería de petróleo y de sistemas informáticos, 

mejorando la conectividad de la base de datos y de gran funcionalidad que 

hacen de esta herramienta un recurso necesario para los ingenieros de 

reservorio, permitiéndole administrar el reservorio y al mismo tiempo 

supervisar la producción. 

 

Utilizando OFM 2002, se puede construir gráficos y reportes, predecir futura 

producción, y crear mapas en dos pasos básicos: 

 Identificar el pozo ó grupos de pozos. 

 Abrir una apropiada herramienta de análisis. 

Todo esto para  poder tomar decisiones oportunas y eficiente en un menor 

tiempo. 
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1.1 HERRAMIENTAS DE OFM 
 
 

En OFM se puede acceder a las herramientas del software a través de la         

barra de herramientas (toolbar), la cual está localizada al inicio de la 

ventana de aplicación debajo de la barra de menús. Para mostrar u 

ocultar esta barra seleccione,  View/Toolbar  de la barra de menú.   

 
Nota:Una marca de comprobación junto al ítem de este menú, indica que  

esta opción esta activa 

 
La opción de la barra de herramientas provee un acceso rápido a muchas 

de las herramientas usadas en OFM. 

 

File Options 
 
 

 
Abre un nuevo documento. 

 

Abre un documento existente. OFM  Muestra la ventana de 

diálogo Open, en el cual se puede localizar y abrir los archivos. 

 

Guarda el documento activo o formato con su nombre actual. Si 

no ha nombrado el documento OFM Muestra la ventana de 

dialogo Save As para poderlo nombrar 

 
Imprime el documento activo 
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View Options 

Agranda o reduce el tamaño de un área seleccionada. 

 

Evita una actualización automática y fija lo que se muestra 

actualmente. 

 
Actualiza la ventana mostrada. 
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Analysis Options 

 
Abre él modulo Plots para gráficos. 

 
Abre el módulo Decline Curve Análisis para análisis de 

curvas de declinación. 

 
Abre el módulo Reports and Log Reports para generación 

de reportes. 

 

Abre la ventana de dialogo Open Grid Map para fijar un 

conjunto de datos (Mapper data set) o abrir un conjunto de 

datos. 

 

Abre la ventana de diálogo  Open Bubble Map para fijar 

conjunto de datos o abrir un grupo de datos existente  

 
Abre los módulos Single Well Log Display y Multi-Well 
Log Display.     

 
Abre el módulo Wellbore Diagram para diagrama de pozos 
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Filter Options 

 

 
Abre el módulo Scatter Plot para gráficos de dispersión. 

 

Abre la ventana de diálogo Open para seleccionar un 

archivo Cross-Section  y crear una nueva cross-section 
para secciones transversales de pozos. 

 

Abre los módulos Material Balance para realizar balance de

Materiales. 

 

Abre la ventana de dialogo BA Input file para abrir archivos 

guardados con la extensión *,BA y abre la ventana de 

diálogo Setup para crear un nuevo análisis.  

 

Abre la ventana Open Contour Map para predeterminar un 

conjunto de datos  mapper data set o abrir un conjunto 

existente. 

 

Abre la ventana de dialogo Open Surface Map para 

predeterminar un conjunto de datos  o abrir un conjunto de 

datos existente 

 
Combina toda la información filtrada en una sola identidad 

 

Remueve toda la información filtrada y Muestra toda la 

información   del proyecto. 

 
Guarda un filtro realizado para  un reporte. 
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 Invierte los pozos filtrados y los no filtrados. 

 
Filtra todos los pozos identificados con una etiqueta. 

 
Guarda cualquier filtrado de pozo en un archivo como una 

lista de Pozos 

 
Guarda cualquier filtrado de pozo en un archivo como una 

lista de Pozos 

 

Abre la ventana de diálogo  Filter by Completion para 

seleccionar una o más completaciones para que sean 

mostradas en el mapa base. 

 

Abre la ventana de filtrado por  Table Data para 

seleccionar las tablas   de datos de OFM a ser filtradas en 

su proyecto, para localizar  rápidamente pozos con un tipo 

particular de datos. 

 
Abre la ventana de diálogo Filter by Category para 

seleccionar un tipo de categoría para filtrar datos. 

 
Abre la ventana de diálogo  filter by Pattern 

 

Abre la ventana de diálogo Filter by Key Match para 

añadir  una lista  de  nombres de o relacionarlos 

directamente con una tabla. 

 

Abre la ventana Filter by Query para definir un 

subconjunto de datos que se desea localizar en la base de 

datos 
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Select Options 

 
 

 

Abre  la ventana de diálogo Well List para seleccionar una lista 

de pozos en un archivo en código ASCII que utiliza un 

comando opcional que equivale a un nombre de filtrado. 

 

 

Avanza hacia el pozo anterior o el siguiente de un grupo de 

Pozos. 
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Edit Options 

Wellbore Options 

 

 

 

Copia el archivo que se muestra en pantalla sea este texto 

grafico a la carpeta que se le asigna. 

 

Inserta el archivo (grafico ó texto) en el documento que se 

muestra en pantalla desde la carpeta que se le asigne 

 

Muestra el cuadro de dialogo Edit Header para editar 

encabezado de texto.  

 

Muestra un menú que modifica las características que se 

muestran de mapa base, tales como asociación de datos, 

símbolos de pozos, anotaciones del mapa, encabezados, Grid 

del mapa, escala del mapa y nombres de pozos. 

 

Abre un cuadro de dialogo para modificar los colores en el 

modulo seleccionado. 

 Muestra la pantalla de forma libre del diagrama de pozos. 

 
Muestra la vista de la columna del diagrama de pozos. 

 Muestra el formato PA del diagrama de pozo. 

 
Muestra una lista de símbolo para usar en el diagrama de 

pozos. 
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Project Options 

 

 

Abre el cuadro de diálogo Calculated Variable para. 

personalizar los atributos del grafico, sistema de unidades, 

definición de ecuaciones,  y atributos del reporte 

 

Abre el cuadro de dialogo Select OFM Table to Edit para 

seleccionar el ítems de los datos individual en OFM con un 

dato de tabla específico.  

 

Abre el cuadro de dialogo Date Range para excluir ó limitar 

los  datos que van hacer utilizado en la curva de declinación 

 
Abre el cuadro de dialogo Delete/Rename para borrar uno ó 

más completaciones de pozos desde su proyecto. 

 
Abre el cuadro de dialogo Edit OFM Multipliers para 

crear,editar,ó borrar múltiples unidades para variables. 

 

Abre el cuadro de dialogo Change Passwords para asociar 

una contraseña con su proyecto para protegerlo de un 

proyecto completo 
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Tools Options 
 

 

 
 
 
 
 
 

 

Abre el cuadro de dialogo PVT Correlations para definir 

correlaciones ó relaciones para varias propiedades del 

petróleo, agua, y gas y además determinar las condiciones de 

superficie y reservorio 

 

Abre el cuadro de dialogo Edit Schema Tables para crear 

tablas en Access, ubicar y reconocer estas tablas en OFM, y 

seleccionar las tablas OFM para automáticamente cargarla 

cuando se abra un proyecto. 

 
Abre el cuadro de dialogo Edit Property para modificar las 

variables definición, reporte, grafico, y atributos matemáticos 

 
Abre el cuadro de dialogo Edit OFM Units para agregar ó 

editar unidades de medidas para su proyecto. 

 

Abre el cuadro de dialogo Edit User Functions para realizar 

operaciones sobre datos ó recuperar información del sistema y 

retornar resultado para el usuario. 

 
Abre el cuadro de dialogo Settings para personalizar su 

proyecto, mostrar mapas, y preferencias de datos.          

 
Abre el cuadro de dialogo Data Registers para tener acceso a 

datos de pozos ó filtros no almacenados en la memoria. 
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1.2 CONCEPTO DE BASE DE DATOS RELACIONAL 

 
OFM es una aplicación que utiliza  tablas específicas para analizar y 

mostrar los datos. En una tabla específica, los datos se almacenan en 

tablas relacionadas por un identificador único. En OFM, las tablas 

específicas son referenciada como un proyecto. 

 
OFM usa tanto MS Access 97 como MS Access 2000 jet engine y 

almacena datos locales en un archivo simple de base de datos  MS 

Access usando una extensión. Mdb 

 
Los proyectos creados en formato MS Access 97 son leído por el MS 

Access 2000 jet engine; Sin embargo, los proyectos creados en formato 

MS Access 2000 no pueden ser leído por el MS Access 97 jet engine. Es 

mejor construir todos los proyectos en la misma versión MS Access 

dependiendo en cual versión de MS Access usted tiene disponible. 

 
En terminología OFM, una tabla específica tiene un campo común clave 

con el cual todos los datos están relacionados. Para una aplicación 

basada en la producción de Oil y la producción de Gas, el factor común 

entre los datos es generalmente la referencia al  pozo, y específicamente, 

la Completaciòn del pozo. OFM asume que la unidad fundamental para 

los datos esta basado en esta Completaciòn definida para cada registro 

de producción.   
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1.3 CREACION DE LOS ARCHIVOS DEL PROYECTO 

Un proyecto OFM puede ser creado de una variedad de métodos. Podría  

ser construido directamente desde su base de dato Access original ( en 

este caso, OFM crearía un sistema de tablas necesarias para el 

proyecto), es decir, los usuarios no tendrán que crear un nuevo proyecto 

OFM(la nueva base de datos Access)  y conectarlo a la base de datos del 

software. Utilizar la propia base de datos de OFM será más fácil  y de 

menor trabajo para el usuario. 

 
Para crear un proyecto se necesitan los siguientes datos mínimos: 

• Coordenadas de los pozos ( X y Y)  

• Nombres de los pozos con las arenas que están produciendo 

• Datos de producción mensual ó diaria 

 

Todos estos datos deben ser llenados en tablas que usan el modelo de 

datos de OFM. 

 
Para manejar los datos mencionados anteriormente se necesita construir 

en un editor de texto (worpad) los siguientes archivos con sus respectiva 

extensiones: 

 
• Archivo definición .def 

• Archivo Sort Data .srt 

• Archivo Static Data .xy 
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• Archivo  Monthly prod .prd 

• Archivo Demo Calculated Variables Data.par 

• Archivo Demo Basemap Anno data.ano 

 

Nota: Los archivos fueron creados de acuerdo a las necesidades de los 

datos del Área Tigre y siguiendo la estructura de los archivos del Demo 

con los que vino instalado el software.  

 
 
1.4 REVISIÓN DE LAS DEFINICIONES DE LAS TABLAS. 

 
Las tablas que se utilizan en OFM son archivos ASCII con extensión *.xy 

para la tabla Master, *.prd para la tabla de producción mensual  y, *.srt 

para la tabla del filtrado. 

 
Tabla Master: La tabla master es la primera tabla definida en el archivo 

definition. Esta tabla es Estática, contiene información de coordenadas de 

pozos, y de otro tipo de información estática tales como profundidad del 

pozo. 

   
Tabla Production: La tabla producción es una tabla  mensual que 

contiene datos de producción mensual del pozo. 

 
Tabla Sort: Es una tabla estática que contiene información de grupos 

para diferentes categorías. 
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1.5 REVISIÓN DE LOS DATOS DE LAS TABLAS PARA EL ÁREA TIGRE 

 
Todos los archivos creados para el proyecto se encuentran en la carpeta 

Text Load Files  del directorio del programa. En estos archivos se 

encuentran las tablas con los datos del proyecto. 

 
1. Doble click en Mi PC 

2. Seleccionar disco local C 

3. Doble click en la carpeta Program Files 

4. Doble click en la carpeta Schlumberger, luego doble click en 

OFM 

5. Seleccionar con doble click la carpeta Sample Databases > 

Demo Database >Text Load Files. 

6. Seleccionar el archivo definición.def  > doble clic 

7. File > Close , abrir el archivo Static Data . xy La tabla 

Master(Headerid) tiene cinco campos definidos : Nombre 

único de la Completaciòn  (Uniqueid), el nombre corto del 

pozo (Alias), coordenada en X del pozo, coordenada en Y del 

pozo y  el wellbore. 
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8. File > Close , abrir el archivo Sort Data. Srt. 

9. File > Close, abrir el archivo Producción mensual. Prd 

 

 

 

 

Fig. 1.1 Archivo Definición.def 
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La tabla Sort Category (Sc) muestra los datos de cinco campo: El nombre 

de la Completaciòn (Uniqueid), el nombre del campo (fieldname), el área 

(lease), la arena productora (Reservoir), y el tipo de pozo (welltype)  

 

 

Fig. 1.2  Tabla Master 
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Fig. 1.3 Tabla Filtro (Sc) 
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Fig. 1.4 Tabla de Producción 
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La tabla monthlyprod muestra también datos de cinco campos: La 

fecha(date), días de producción(days), producción de petróleo(oil), 

producción de gas(gas), y producción de agua (water). 

 

1.6 CREACION DE UN NUEVO PROYECTO 

 
En esta sección, usted selecciona crear un nuevo proyecto con archivos 

de texto proporcionados por el directorio del programa en la carpeta “Text 

Load Files”. 

1. Dentro de OFM. 

2. Seleccionar File > New. 

3. En la ventana New OFM Proyect, en el cuadro de texto File  

Name, ingresamos el nombre que usted desee usar para el        

proyecto. En este caso ingresar el nombre “Proyecto tesis” en 

la carpeta OFM.           
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4. Click OK. En la trayectoria del campo, verificar que el directorio        

y el nombre del archivo estén correcto. 

5. Activar la opciòn Create it from the data sources specified   

                      below. 

6. Seleccionar ASCII Flat Files de la lista desplegable Data  

                      Source. 

7. Activar cualquier versión de Access 97 ó Access 2000 para  

                      crear su base de datos OFM.                  

8. Click OK. 
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1.7   USAR ARCHIVOS ASCII PARA CARGAR Y DEFINIR LA   

        ESTRUCTURA DE LA BASE DE DATOS OFM. 

 
  Una vez creado el nombre del archivo para nuestro proyecto, a  

  continuación cargar los archivos necesarios para el proyecto tesis y 

  definir  la estructura de la base de datos OFM. 

 

1. En la ventana OFM Data Loader, ubicar la carpeta Text Load                   

Files para mostrar la lista de archivos(OFM /Sample Database 

/Demo Database /Text Load files). 

2. Agregar los siguientes archivos en este orden, para cualquier       

                      archivo hacer doble click, ó seleccionar el archivo y click Add:  

 

• Archivo definición. def 

• Archivo Static Data. xy 

• Archivo Sort Data. srt 

• Archivo Producción Mensual. prd 

• Demo Basemap Anno Data. ano 

• Demo Calculated Variables Data. par 

• Demo Basemap EWL Anno data.ano 
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3. Click Load para mostrar el mapa base. 

4. Click en el cuadro Errors y Status en la ventana OFM Output.     

           Observen los errores si es que existen y verifique que todas las     

                      Tablas hallan sido cargadas dentro del proyecto. 
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Fig. 1.5 Mapa Base del Área Tigre 
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CAPITULO 2 

PERSONALIZACION DEL MAPA BASE 

 
2.1 INTRODUCCIÓN 

 

El mapa base es lo primero que se observa en la pantalla cuando abrimos 

un proyecto OFM, es la ventana central de OilField Manager sirviendo 

como plataforma de lanzamiento de puntos para esta aplicaciones de 

ingeniería y de geología. Después que los datos son cargados, OFM 

genera un mapa base, este mapa base puede ser utilizado como un 

buscador para seleccionar pozos ó como una herramienta para visualizar 

los datos del proyecto antes del análisis.  Esta es posiblemente la ultima 

ventana que se observa antes de cerrar nuestro proyecto. Se puede 

cerrar algunas otras ventanas sin que se cierre el mapa base, pero si 

cerramos el mapa base, el proyecto es cerrado y todas las otras ventanas 

son automáticamente cerradas. 

 

 

 



 32

Manejando correctamente el mapa base nos permite ayudar a reducir 

confusiones y errores.Esto es, mas o menos, una herramienta de 

visualización.  

Las opciones de edición del mapa base son accesibles a través del menú  

Edit > Map Los cambios de On/ Off para la leyenda del mapa, nombres de 

pozos, y desviaciones desde el menú View.   Informacion de anotaciones 

puede ser agregado a el mapa base desde la selección Edit > Map > 

Annotations ó desde el menu Tool > Map Annotations. 

2.2 ASOCIACIÓN DE MAPAS 

 

La primera cosa que usted necesita hacer después de crear y cargar su 

proyecto es revisar su asociación de mapa .OFM provee alternativas para 

activar  las diferentes característica del mapa , seleccionando 

Edit > Map > Association , y click OK. 

1. Well Type – Table es idoneo la asociacion para mostrar su pozos ,el 

color , y atributos.Se puede asociar estas especificaciones del mapa a 

algunos de sus campo de textos en algunos de sus tablas estatica. 

Seleccionar SortCategory.Lease desde la lista. 

2. Click OK 
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3.  El resto de la asociacion podría explicarse por si mismo. Si se conoce 

que campos en su base de dato corresponde a los campos del mapa 

OFM, asociarlo entonces en este proyecto, esto es lo que 

posiblemente OFM podría sugerir los correctos campos, así no se 

tiene que hacer ningun cambio. 

4. Revisar si todos el mapeado esta correctamente construido,click 

OK.El mapa base se muestra con los colores y atributos de los pozos. 

5.   Sobre el mapa base, click derecho y seleccionar Legend > Move. 

6.   Dentro del cuadro dashed, click y mantener presionado el boton 

izquierdo del mouse,entonces arrastramos el cuadro para su ubicación 

deseada, y soltamos el boton izquierdo del mouse. 

7. Mover la direccion del mouse desde el cuadro y luego aceptar.El 

cuadro de leyenda se mueve a la nueva posicion. Se puede ademas 

hacer click derecho y seleccionar Done para conseguir el mismo 

resultado. 

 

Ahora utilizaremos otro criterio de tipo de pozo para el mapa 

base.Seleccione Edit > Map>Association. 

    

1. Seleccionar SortCategory.WellType desde la lista seleccionada para 

Well Type- Table. 
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2. En la ventana Well Symbol, activar Default. 

3. Hacer click dos veces y regresamos al mapa base. 

4. El mapa base reaparece, con el tipo de pozo. 

2.3  CREACIÓN DEL  NOMBRE DE POZOS 

 
1. Seleccionar Edit > Map > Well Names. 

 

 

 

 

 

 

 

            

 

 

2. En la ventana Well Name, especificar abajo como mostrar el nombre 

del pozo ( 0 significa default, no quiere decir que el tamaño del texto 

es cero) 

3. Click OK para retornar al mapa base. 
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4. Como se puede observar, el nombre del pozo es muy largo para 

poderlo distinguir sobre el mapa base.Seleccionar Edit > Map > Well 

Name y activamos Alias Name 

5. Click OK el nombre corto del pozo si se lo puede distinguir sobre el 

mapa base  

 

  

 

Fig. 2.1  Ubicación de los pozos del área Tigre 
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Fig. 2.2 Ubicación de los pozos del área Tigre (Nombre Corto) 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

2.4 FIJACION DE LIMITES AL MAPA 

 

En este procedimiento, se podra utilizar las caracteristicas de Limits / Grid 

para ver las opciones del Grid y el Frame en el mapa base . 
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1. Seleccionar Edit > Map > Limits > Grid desde el menu de barra 

El cuadro de dialogo del Map Grid se muestra 

2. Activamos la opcion Grid and Frame, y especificamos el resto como se 

muestra abajo.      

                     

 

 

 

 

 

 

 

 

 

 

           

3. Click OK. 

El mapa base se muestra con el Grid y el Frame 
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Fig 2.3 Pantalla completa del mapa base con su respectivo 

marco y grillas.

 

 

 

 

 

 

 

 

 

 

 

 

 

     

 

 

4. Seleccione Edit > Map > Limits > Grid 

5. Hacer lo siguiente: 

Activamos la opcion Don’t asegurece que la opcion Show Numbers 

este seleccionada 
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6. Click OK. 

El mapa base se muestra sin el Grid y sin el Frame 

 Nota: Cada vez que cambiemos los limites del mapa (cambiemos X y Y 

minimos y maximos) asegurece de hacer click en Set Limit.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Fig. 2.4 Pantalla completa del mapa base sin mostrar el marco y 
grillas. 
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2.5 ENCABEZADOS AL MAPA BASE. 

 

1. Seleccionar del menu de barra Edit > Map > Headers. 

2. En la primera celda de la ventana Edit Headers, ingresar “OilField 

Manager 2002”. Click Enter ó click para la segunda celda. 

 

 

 

        

 

 

 

 

 

 

 

3. Click en el botón Font, y especifique las cualidades de la fuente como 

usted desea para cada una de las celdas por separado 
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4. Click OK dos veces para retornar al mapa base. 

5. posecionarse en el encabezado haciendo click izquierdo del mouse, 

luego lo trasladamos a una nueva ubicación (a la izquierda del mapa 

base) manteniendo presionado el boton izquierdo, posteriormente lo 

soltamos, y Enter. 

 

 

 

 

 

 

 

 

 

 

 
Fig. 2.5 Mapa Base con su primer encabezado 
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6. Seleccionar Edit > Map > Headers. Repetimos los pasos anteriores 

para la segunda celda e ingresar “Proyecto Tesis”  

 

 

 

 

  

 

 

 

 

 

 

Nota: El Headers tienen su propia opcion del menu( el mismo menu si 

se arrastrara y click derecho del mouse). Utilizar  click derecho 

para acceder a la opcion. Se puede cambiar la fuente ó realizar 

algunas operaciones móviles con relativa  facilidad. 
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2.6 ESCALAS AL MAPA BASE 

 

La escala del mapa se la utiliza sobre todo para mostrar las unidades de 

la leyenda(por ej: coordenadas)y controlar la salida( impresión , por 

ejemplo). OFM muestra su mapa base en la escala mas razonable que 

pueda calcular. Las unidades mostradas con las especificaciones de 

escala se van a especificar en la opcion  de unidades Legend > Display. 

 

 

 

Fig 2.6  Mapa Base con su segundo encabezado 
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1. Seleccionar en el menu de barra Edit > Map > Scale 

2. En la ventana Map Scale, activar en el cuadro Legend English 

3. En la lista desplegable Display unit, seleccionar None 

4. Activar la opcion inch para el cuadro Scale(el resto lo obviamos)   

5. Click OK. 

                                    

 

 

 

 

 

 

 

                 

                                   

2.7 ANOTACIONES AL MAPA BASE 

 

En esta sección se podrá ubicar y observar los archivos utilizado para 

mostrar las anotaciones del mapa para el proyecto tesis. 
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1. Seleccione Edit > Map > Annotations desde el menu de barra. 

El cuadro de dialogo Map Annotations se exhibe 

2. Seleccione el primer archivo anotaciones 

3. Click Remove. 

 

 

 

 

 

 

 

 

 

 

         

 

4. Click Add. 

Se abre el cuadro de dialogo de la ventana OFM Data Loader 

5. Seleccionar la carpeta Text Load Files 

6. Seleccione el archivo Demo Base map Anno data.ano 
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7. Click Add. 

8. Click Load. 

Nota: Para ver el archivo anotación, primero selecciónelo, y en 

seguida click Current. 

9. Click OK. 
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Fig. 2.7 Mapa Base con sus anotaciones seleccionadas 

El mapa base se muestra con las anotaciones seleccionadas. 

     

 

 

10. Seleccione Edit > Map > Annotations 

11. Click Add y seleccionamos el otro archivo .ano en la carpeta Text Load 

Files 
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12. Click Add. 

13. Click Load. 
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Fig 2.8 Mapa Base con sus Dos Archivos de Anotaciones 

14. Click OK. 

 

       El mapa base se muestra con los dos archivos de anotaciones 

seleccionado. 

           

 

 

             

 



 50

 

 
 
 
 

CAPITULO 3 

FILTROS 

 
3.1 INTRODUCCION 
 

Filtrado significa la creación de un sub-cojunto de datos 

compuestos de pozos individuales ò de completaciones. El 

concepto de filtrado en OFM ha sido probado en ser muy 

práctico para todos los usuarios , con un buen criterio de filtro 

se puede realmente optimizar el tiempo para realizar el análisis, 

garantizando resultado correctos, y después de todo, maximizar 

la productividad .Los filtros pueden ser : 

 

• Exhibido en el mapa base 

• Agrupados 

• Utilizado para presentaciones ò análisis 

• Guardado y utilizado para presentaciones y análisis posteriores 
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3.2 FILTRADO POR COMPLETACION 

 

Lo primero y probablemente lo mas frecuentemente utilizado en las 

operaciones de filtros es Filter > Clear. Para garantizar que su criterio de 

filtro esta siendo aplicado a todo el sistema de pozos, verificar que todos 

los filtros previos estén limpios . Hay además un botón en la barra de 

herramienta el “ Clear Filter”  

 

1. Seleccionar Filter > Filter By  > Completion   

2. En la ventana Filter By Completion , click para seleccionar las 

completaciones  

 

a . ANC_0580:AT 

b . ANC_0798:AT 

c . TIG_0001:AT 

 

3. Click OK para mostrar el mapa base con las completaciones 

seleccionadas  
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Mapa Base de los Tres Pozos seleccionados 
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   4. Seleccionar Filter > Group Data , en la lista desplegable muestra(3), 

indicando  que se tiene agrupado las tres completaciones 

  

5. Limpiar el filtrado con el botón Clear Filter  para retornar al mapa base  

     

  Nota: Para observar la lista de las completaciones seleccionadas para el 

filtro. Activar la ventana Output, del cuadro del filtro 

         

            

 

 

3.3 FILTRADO POR TABLA DE DATOS                                                  

 

El cuadro de dialogo filtrado por tabla de datos es utilizado para 

seleccionar los datos de las tablas OFM para ser filtrado en el proyecto y 

localizar rápidamente los pozos con un tipo particular de datos  

 

1. Seleccionar Filter > Filter By > Table Data. 

2. Seleccionar la tabla MONTHLYPROD de la lista de tablas y 

agregamos OK.  
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3. El mapa base se redistribuye con la lista de pozos que tienen datos de  

producción mensual, seleccionamos la ventana OUTPUT del cuadro 

Filter, se muestra el numero de pozos que cumplen con este criterio 

de filtro. 
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Limpiar el filtro y retornar al mapa base original. También  se puede hacer 

el filtro para la tabla Sort Category ( Sc ) repitiendo los pasos anteriores.   

 

 

 

Fig 3.1 Filtrado por tabla de producción mensual. 
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3.4 FILTRADO POR CATEGORÍAS 

 

El cuadro de dialogo filtro por categoría se lo utiliza para seleccionar un 

tipo de categoría para filtrar los datos, el prerrequisito para esta operación 

es que las categorías utilizada tienen que haber sido construida 

previamente en el proyecto 

 

1. Seleccionar Filter > Filter by > Category  y seleccionar Reservoir 

2. Click OK 
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3. En la ventana de Reservoir, seleccione la arena  productora Atlanta y 

agregar dos veces OK el mapa  base se muestra con los pozos que 

producen de esa arena 

 

4. Repetir los pasos anteriores y seleccionar el reservorio Socorro 

 

 

 

Fig. 3.2  Filtrado por Categorías (Reservorio Atlanta) 
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Nota: Podríamos aplicar otros filtros con otro tipo de categoría, como por 

ejemplo : Tipo de pozos, por áreas,  y por nombres de campos , pero, 

los datos que se esta analizando corresponden a datos de pozos 

únicamente de petróleo de una sola àrea “Tigre” y de un solo campo 

 

Fig 3.3 Filtrado por Categoría (Reservorio Socorro) 
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“Gustavo Galindo” por lo que no se pueden hacer estos filtrados , hace 

falta otra variable.      

 

3.5  FILTRADO POR CONSULTA 

 
       Una consulta es un llamado a la base de datos del proyecto para que 

defina un subconjunto de los datos totales. Hasta ahora, hemos visto 

varias técnicas de filtrado que trabajan con solo datos estáticos (Ej.: 

varias clases de categoría), pero los mas importantes son los datos de 

producción que cambian con el tiempo .Ejemplos: 

        Una consulta para pozos con una taza de producción de petróleo mayor 

a 100 barriles 

       Como resultado de esta pregunta, OFM puede mostrar los pozos que 

producen mas de 100 barriles 

 

1. Seleccionar Filter > Filter by > Query. 

2. En la ventana Filter by Query, seleccionar en el cuadro de la lista 

desplegable  By UNIQUEID 

3. Click Edit 
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4. En la ventana de texto Select UNIQUEID where, ingresar la variable 

calculada “Monthlyprod.Oil > 500” 

5. Click OK 
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6. Las demás opciones de la ventana Filter by Query omitirlo  por default, 

click OK y se muestran los resultados del Query en el mapa base 

 

 

               

 

Fig. 3.4   Filtrado por  Consulta 
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 Ahora  realizar una consulta para los pozos que producen mas de 1000 

barriles a partir del uno de junio de 1996 

 

1. Seleccionar Filter > Filter by > Query > Edit. 

2. Ingresar entre paréntesis , la variable calculada y la fecha 

(Monthlyprod.Oil)&(Date >= 19960601) 
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3. Click OK , en la ventana Filter by Query ingresar 1 en el cuadro de 

ocurrencia , luego OK    

 

 

 

Los resultado del Query se muestra a continuación en el mapa base , 

en la ventana del Filter  y finalmente en la lista desplegable del menú 

de barra 
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Fig 3.5 Filtrado por Consulta; para Pozos que Producen Mas de 1000 
Barriles por Día. 
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3.6  FILTRADO POR SELECCIÓN DEL MAPA BASE 

OFM permite realizar filtrado seleccionando directamente el pozo desde 

su ubicación en el mapa base y poder realizar varios tipos de filtrado tales 

como: Filtrado por reservorio, tipo de pozo, por campo y finalmente por 

área 

 

1. Identifique el pozo sobre el mapa base y señálelo con el cursor 

2. Doble click sobre el pozo, y se muestra la ventana Select 

completions 

3. Seleccionar un tipo de filtrado en la lista desplegable Additional 

Information y obtenemos la información del pozo 
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Nota: Esta opciòn se ejecuta solo para pozos que producen de 
varias arenas productora. 

 
DEFINICIONES 
 
Clear Filter : Esta opción limpia algunos filtros previos que se tiene en el 

proyecto antes de ejecutar el Query  

Load After :  Utilizada para agrupar y cargar los datos dentro de la memoria, 

utilizando. La opción Group chequeada en Tool > Setting       

Occurrences : Este cuadro de texto es donde se especifica cuantas veces 

usted necesita  el criterio del Query para ser aplicado a los datos 

Consecutively : Esta opción de trabajo conjuntamente con la anterior sirve 

para especificar que esta ocurrencia tiene ser consecutiva y no aleatoria 

By : Se puede aplicar el criterio del Query para algunos niveles de categoría 

así como los niveles de Completaciòn y el Alias , usando esta lista 

desplegable. 

Save :  Usted puede guardar el criterio del Query con esta opción. 

Open :  Se puede usar la opción Save otra vez con esta opción.   
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CAPÍTULO 4 
 

GENERACION DE GRAFICOS  

Y REPORTES DEL AREA TIGRE. 

 
 

4.1 INTRODUCCIÓN 

Unos de los módulos mas conocidos del programa de  análisis de pozos y de              

yacimiento en el  Oilfield Manager es el modulo de Plot y Report que muestra 

gráficamente y tabuladamente la información numérica 

En la sección de graficación se puede definir las diferentes 

funcionalidades de graficación tales como : 

 
• Numero ilimitado de ventanas de gráficos 

• Numero ilimitado de curvas por gráfico 

• Varios tipos de gráficos como Acumulado, promedio y porcentaje 

de contribución 

• Visualizar en un solo gráfico las curvas de selecciones y categorías 

tanto activas como fijas  

• Crear gráficos múltiples en una ventana de gráficos. 
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Los reportes pueden contener variables calculadas , datos de entrada 

tomados directamente  de la base de datos . Una vez creado el reporte, se  

puede guardar para un análisis posterior . Generalmente, hay dos tipos de 

reporte que se pueden generar en OFM: 

• Reporte basado en la fecha 

• Reporte basados en resumen 

 
Los reporte basados en la date , la fecha referencial aparece como una  

columna de el reporte. En este ejemplo , la taza de Oil y Water son 

 reportadas mensualmente. 

 

              

 

 

 

 

 

 

 

 

 

 

Fig. 4.1 Tabla de Reportes de Basados en Fechas 



 69

En un reporte Summary, los datos son clasificados por entidad. En este 

ejemplo, la producción acumulada de petróleo y agua es reportada por 

reservorio. 

: 

 

 

 

 

 

 

 

 

 

 

 

4.2 CREACIÓN DE GRÁFICOS SOBRE UNO Ó DOS EJES 

 
1. Seleccionar Filter > Filter by > Completion 

2. Escogemos los pozos para graficar, agregamos OK y aparecen los 

pozos seleccionados en el mapa base, luego los agrupamos del menú 

de barra 

 

 

Fig. 4.2 Tabla de reportes de producción de reservorio 
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3. Seleccionamos Analysis > Plot 

4. Edit > Plot ( doble click sobre el grafico y seleccionamos Edit > Plot) 

5. En la ventana Edit Plot mostramos la pestaña activada Plot data 

6. En la selección del campo Graph 

Numero de grafico = 1 

Grafico actual = Graph 1 

7. En la selección del campo Y Axis: 

Fig. 4.3 Mapa base producto del filtrado  
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Numero de ejes = 1 

Eje actual = Y- Axis 1 

8. En el grupo X-Axis, seleccionamos Date para la variable y 1 para el 

múltiplo. 

9. Sobre el cuadro de grupo del Plot , activamos Regular. 

 

 

 

 

 

 

 

 

 

 

 

 

                  

 

10. Seleccionar la opción Add Múltiple Curves y en la ventana agregar la 

variable” Monthlyprod.Oil” click OK 
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11. Click en la pestaña Curves  

12. Verificar que la lista de curva mostrada sea la curva correcta , 

seleccionar 1 de la lista multiplier 

13. En el cuadro Line seleccionar para cada pozo lo siguiente: 

. Seleccionar Red para el color 

. Solid para el tipo 

. Seleccionar un tamaño de 4 

. En el cuadro de Step no activar 

14. En el cuadro Point, no cambiar (None para el tipo, tamaño de 3) 

15. En la caja Fill, no modificar ( None para el interior, Horizontal para el 

estilo)  

16. En el cuadro Post, no cambiar. Entonces sería “None”, “Above”, “0”, y 

el cuadro Post Annotation no activarlo.  

17. No hacer click OK todavía. 
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18. Seleccionar la pestaña Axes. 

19.  Verificar el tipo de escala para la Date, en el eje X 

20. Verificar que en el eje Y sea Logarithmic. 

21. Cambiar el color del Grid y el Tick a color Gray  

22. Click sobre el botón Font del Grid y el Tick, cambiamos el tamaño a 9 

23. No hacer click OK todavía. 
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24. Click en la pestaña Graph. 

25. Activar el Show y Box, lo demás no cambiar 

26. No hacer click  OK todavía 

 

                        

 

 

 

 

 

 

 

 

 

 

27. Click en la pestaña Headers, verificar que el cuadro Show header este 

activado. 

28. Click en Add, luego click Assist y agregar el primer encabezado 

29. En la ventana Create Header, ingresar la función “@name( )” 

30. Click OK. 

31. Click en la Font y seleccionar los atributos para el encabezado, luego 

OK. 
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 Fig. 4.4 Producción mensual de petróleo 
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32. Finalmente OK para mostrar el grafico. 
 

Ahora  mostrar un grafico con dos ejes , agregar la variable 

acumulado de petróleo para las tres completaciones 

seleccionadas. 

 
1. Abrimos la ventana Edit Plot , seleccionando Edit > Plot. 

2. En el lado derecho  del cuadro Y Axis, seleccionamos 2 para el 

numero de ejes. 

3. Para el cuadro de la derecha Current Axis, ingresamos Y- AXIS 2 

4. Click en la opción Add Multiples Curve y seleccionamos la variable 

Oil.Cum luego OK. 

5. No seleccionamos Aceptar en la ventana principal (se puede hacer 

click Apply si se desea hacerlo). 
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6. Click en la pestaña Curves. 

7. Seleccionar los atributos para la curva Oil.Cum  

          Oil.Cum :TIG_0010: AT 

Color = Cyan 

Type = Dashed 

Width = 4 

Multiplier = M  

          Oil Cum : TIG_0014: AT 

Color = Yellow 

Type = Dashed 

Width = 4 

Multiplier = M 

          Oil. Cum : TIG_1001: ST 

Color = Magenta 

Type = Dashed 

Width = 4 

Multiplier = M 

 

8. No hacer click OK todavía 
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9. En la pestaña Axes, verificar la escala en el eje Y = Linear. 

10. Click OK para mostrar el gráfico 

 

 

        
Fig. 4.5 Producción mensual de petróleo sobre dos ejes 
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4.3 MULTIPLES CURVAS SOBRE UN GRÁFICO 

Con el fin de crear un grafico con varias curvas de producción para un 

único pozo, seleccionar lo siguiente : 

 

1. Filter > Filter by > Completion 

2. Seleccionamos el pozo  TIG_1002: ST   

3. Click OK, el pozo se muestra en el mapa base 

4. Seleccionar Analysis > Plot 

5. En la pantalla del Plot, seleccionamos Edit > Plot ( también podemos 

entrar posesionándonos sobre el grafico , doble click ó click derecho y 

seleccionamos Edit )  

6. En el cuadro de dialogo Edit Plot.Elegida la solapa Plot data, 

seleccionamos la variable X-Axis como Date y la variable Plot como 

regular .Haga doble click en el botón Add Curves   

7. Click en el botón Add Múltiple Curve , seleccionamos la variable 

Monthlyprod.Oil, luego agregamos dos curvas mas y seleccionamos 

las variables Monthlyprod.Water  y finalmente la variable Oil.Cum     
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8. Click en la pestaña Curves y le damos los atributos a las curvas 

seleccionadas 

9. Seleccionar el tipo de escala en la pestaña Axes , escogemos 

Logarithmic  

10. Haciendo Click en OK aparece el grafico semilogaritmico de 

producción    
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4.4 MÚLTIPLES GRÁFICOS EN UNA HOJA 

 
 

En esta sección vamos a mostrar un segundo grafico que ha de 

adicionarse al grafico de varias curvas de producción del pozo 

TIG_1002:ST mostrado en la sección anterior y compararlo con la 

producción acumulada de petróleo del pozo, de su yacimiento , y de su 

campo. 

 

Fig. 4.6 Grafico de múltiples curvas  
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1. Desde la ventana de gráficos, seleccione Edit > Plot en la barra  de 

menú para abrir el cuadro de dialogo Edit Plot      

2. En el panel Graph, seleccione 2 en la lista desplegable Number of 

Graphs  y Graph 2 en la lista desplegable Current Graph 

3. Elegida la solapa Plot Data, seleccione la variable X-Axis como DATE, 

y la variable Plot como Regular 

4. Click en el botón Add Curves, luego seleccione los siguiente 

elementos de la lista desplegable: 

Variable 1 como Oil.Cum 

Category 1 como UNIQUEID 

Name 1 como TIG_1002:ST 

5. Click en el botón Add Curves , para la segunda y tercera curva 

seleccione los siguientes elementos de la lista desplegable 

Variable 2 como Oil.Cum 

Category 2 como Reservoir 

Name 2 como Current 

Variable 3 como Oil.Cum 

Category 3 como Field 

Name 3 como Current 
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6. Para individualizar las curvas, hacer click en la solapa Curves, 

seleccione en la lista desplegable Current Curves 1: 

Oil.Cum:Current:TIG_1002:ST  

7. Seleccione BLUE en la lista desplegable Line Color.Haga lo mismo 

para las curvas 2 y 3 con los colores Green y Red respectivamente 
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8. Haga click en la solapa Graph, seleccione Graph 2 de la lista 

desplegable Current Graph y desactive el cuadro Show para la 

leyenda.  

9. Click OK para mostrar el gráfico 

  

 

 

 

 

 

 

 

 

 

 

 

          

Para poder distinguir la producción acumulada de petróleo para un pozo, 

su yacimiento y su campo, los encabezamiento del programa OFM serán 

 reemplazado por  rótulos para poder distinguir cada una de las curvas. 

 Seleccione lo siguiente: 

 

Fig. 4.7 Múltiples gráficos en una hoja  
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1. Edit > Plot en la barra de menú ,una vez abierto el cuadro de dialogo 

Edit Plot haga click en la solapa Headers 

2. Triple click en el botón Add y aparecerán tres líneas bajo Headers 

3. En la fila 1, ingrese la función” @loadname( )”ahora haciendo click en 

el botón Font, se abrirá el cuadro de dialogo Font, seleccione BLUE 

en la lista desplegable Color y seleccione el fondo como Opaque, 

luego pulse OK 

4. Para la fila 2, ingrese la función “Sc Reservoir” luego haga click en el 

botón Font, seleccione Green en la lista desplegable Color, y 

seleccione el fondo como Opaque, luego OK 

5. En la fila 3, ingrese la variable “Sc.Fieldname” luego nuevamente click 

en el botón Font, seleccione Red en la lista desplegable Color, 

seleccione el fondo como Opaque y haga click en OK  

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Fig. 4.8 Múltiples gráficos en una hoja con encabezado   
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GRÁFICOS DE HISTORIA DE PRODUCCIÓN INDIVIDUAL Y DE GRUPOS 
DE POZOS 
  

1. Abrir y editar el Plot, crear un grafico simple con un solo eje. Utilizar 

Date como la variable horizontal., Regular para el tipo de Plot  

2.  Remover todas las curvas , seleccionar Remove All desde la ventana 

Y-Variable 

3. Click en el botón Add Múltiple Curves. 

4. En la ventana Add Múltiple Curve, seleccionar UNIQUEID para la 

categoría y Monthlyprod.Oil para la variable. 

 

              

                     

 

   

5. Click OK para retornar  a la ventana Edit Plot. OFM agrega un numero 

de curvas Monthlyprod.Oil a la lista basado en el numero de 

UNIQUEID disponible en la lista de pozos 

6. Cambiar para la solapa Curves y comprobar que OFM haya asignado 

automáticamente los colores para las curvas( basado en el numero de 

curvas y el numero de colores definido en OFM, la secuencia de 

colores podría ser repetido) 

Usted no necesita cambiar nada en esta sección.
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7. Seleccionar All Curves desde la lista Current Curves , y entonces 

asignamos Solid para el tipo y 4 para el tamaño. 

8. No hacer click todavía 

9. Vaya ahora a la pestaña Axes. Chequear y verificar que en los dos 

ejes estén determinadas la variable Date para el eje X, y la escala 

Linear para el eje Y 

10. Click OK para mostrar el gráfico 
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 Fig. 4.9 Grafico de historia de producción de pozos individuales 
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11. Del menú de barra del Plot, seleccionar el icono Sum para mostrar la 

producción acumulada de todos los pozos del área “Tigre” 

 

 

     

 

12. Otro tipo de Plot que presenta OFM es el gráfico Apilado (STACKED) 

 

 

Fig. 4.10 Grafico de la producción acumulada de todos los pozos  
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4.5 CREACIÓN DE VARIABLES CALCULADAS 

Cuando usted crea una variable calculada en OFM , se necesita 

considerar las variable Prefix y Name, también las ecuaciones, las 

unidades, y el múltiplo que va utilizar la variable y la forma en que 

quisiera que la variable apareciera en el grafico y en el reporte. 

Las variable calculadas permite realizar operaciones usando datos del 

proyecto.Pueden ser simples expresiones ó pueden involucrar funciones 

múltiples del sistema y del usuario. Las variables calculadas para un 

proyecto pueden ser creadas, editadas, y borradas, así mismo, realizan 

Fig. 4.11 Grafico de historia de producción de pozos individuales (STACKED)  
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una operación aritmética después que los datos son agrupado en ofm, 

producto de la suma. 

 
Las  variables que vamos a calcular son: Acumulado de petróleo y Agua, 

tasa máxima de petróleo, GOR, y WOR . 

 
1. Seleccione Edit > Proyect > Calculated Variables. 

2. Desde la ventana Calculated Variables editamos la variable” CUMOIL” 

(chequear que el cuadro Prefix este activado) 

3. Click Add. 

4. En la ventana Edit Calculated Variable, ingresar la 

función”@CumImput (Monthlyprod.Oil)” en el cuadro del texto. 
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5. Click OK. 
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6. De la solapa Define, de la ventana Edit property, seleccionar bbl para 

las unidades. 

7. En la solapa Report, seleccionar 3 para los decimales, y cambiar el 

encabezamiento para las dos filas, Cumulative, y Oil 

8. Sobre la solapa Plot, ingresar Cumulative Oil en el cuadro del nombre 

Plot. 

9. Seleccione Green, Solid, y 4 para la Line Attributes. 

 

                

 

 

 

 

 

 

 

 

 

 

10. En la solapa Math, seleccionar M para el múltiplo 

11. Click OK. La variable CV.CumOil ha sido agregada para el proyecto 
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Nota: Repetimos los pasos anteriores para calcular la variable producción 

acumulada de Agua. 

 

 

 

 

 

 

 

 

 

 

 

Ahora usted puede aprender a crear una variable calculada que retorne la 

máxima taza de producción de petróleo para cada pozo. Se puede incluso 

reportar la fecha donde esa producción fue máxima. 

 
1. En la ventana Calculated Variable, editar la variable “MaxOil” luego 

click Add.  
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2. En el cuadro de texto de la ventana Edit Calculated Variable, ingresar 

la función “@Tmax (Monthlyprod.Oil, Monthlyprod.Oil > 0)” 
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3. Click OK. 

4. En la solapa Define, seleccione bbl para la unidad. 

 

 

 

 

 

 

 

 

 

 

5. En la solapa Report, ingresar Max Oil Production para el encabezado 
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6. En el Plot, ingresar Maximum Oil Production en el cuadro del Name 

plot 

 

7. Seleccione None para Line Type Attributes, Dark Red, Filled Star, y 5 

para los Point Attributes. 

8. Finalmente OK. 

La siguiente variable que se va a calcular es el WOR (Relación Agua- 

Petróleo). 

 
1. En la ventana Calculated Variables , ingresar la variable “WOR”, y 

luego click Add ( revisamos que el cuadro Prefix este activado) 
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2. En la ventana Edit Calculated Variables, definimos CV.WOR como 

Monthlyprod. Water / Monthlyprod.Oil. 

3. Click OK. 
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4. Asignar los atributos para la variable.bbl / bbl como la unidad, y 1 para 

el múltiplo. 

 

                    

 

 

 

 

 

 

 

 

5. En la solapa Report, ingresar Water-Oil Ratio para el encabezado, 

trabajar con 3 dígitos decimales.    
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6. En la sección de plot ingresar el nombre de la variable en el cuadro de 

texto Name Plot. El resto no se hace ningún cambio. 

7. Click en Aceptar, y construir una nueva variable de producción 

Para la variable GOR repetir los pasos anteriores del 1 – 7 

 

4.6 GENERACION DE REPORTES DE PRODUCCIÓN MENSUAL 

 

     Cada una de las  variables de OFM pueden ser reportadas. Todas  

pueden ser tomadas de la lista de variables del proyecto en la ventana 

Edit Report. 

 
En esta sección se puede presentar reporte de producción mensual de 

petróleo, gas, y agua, así como también varias alternativas en la 

presentación de reportes OFM. 

 
1. Agrupar todos los pozos juntos seleccionando Filter > Group Data. 

2. Seleccionar Analysis > Report del menú de barra (ó click en el botón 

de la barra de herramienta Report) 

3. OFM guarda el ultimo reporte que usted corrió en este proyecto, así  

que usted tiene ya una salida haciendo doble click en cualquier lugar 

en el reporte ó seleccionando Edit > Report Parameters ( ó click 

derecho en cualquier lugar en el reporte y seleccionar Report 

Parameters) para acceder a la ventana Edit Report. 
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4. En el cuadro de texto, ingresar @name(),date, monthlyprod.oil, 

monthlyprod.gas, monthlyprod.water.  

5. Click OK  

 

                    

 

 

 

 

 

 

 

 

 

 

6. Como se puede observar, la primera variable @name() es una 

variable estática por que es constante con respecto al tiempo. Las 

otras variables son de frecuencia mensual. Click en el botón  Next y 

se muestra los datos de producción mensual para cada pozo. 

7. Seleccionar TIG_0010:AT y se muestra los datos de producción para 

este pozo 
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8. Hacer doble-click en el report y adicione en la ventana Edit Report las 

variables sc.reservoir, y cum.oil 

 

                

 

 

 

 

 

 

 

 

Fig. 4.12 Generación de reportes de producción mensual 

Fig. 4.13 Reportes de producción mensual del pozo TIG_0010:AT 
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9. Click OK. El reporte  muestra las dos variables adicionales.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Fig. 4.14 Reportes de producción mensual con las dos 
variables adicionales 
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Nota: @name() es un sistema de función, usted puede hacer click en el 

botón System Functions y seleccionar Name de la lista desplegable. El 

signo @ y los paréntesis son automáticamente agregado para denotar 

que esto es un sistema de función de OFM. 

 
Click Add para agregar esta función a el cuadro de texto Select ( usted 

puede agregar haciendo doble-click en la variable y automáticamente se 

carga al cuadro de texto Select). 

 
Date, monthlyprod.oil, monthlyprod.gas, y monthlyprod.water todas son 

variables de entrada. Para acceder a las variables , se puede hacer click 

en el botón Proyect Variables y se muestran todas las variables del 

proyecto en el cuadro de la lista desplegable. 

 

4.7 CREACION DE REPORTES BASADOS EN EL FILTRADO 

 
1. Seleccionar Filter > Filter By > Category > Reservoir > Atlanta 

2. Click OK dos veces. 

3. En el menú de barra seleccionar Analysis > Report 

4. En la ventana Edit Report ingresamos la función @name(),y las 

variables date, monthlyprod.oil, monthlyprod.gas, monthlyprod.water, 

cum.oil 

5. Click OK 
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6. Click. En el botón Group del menú de barra para agrupar a todos los 

pozos 

 

 

               

 

 

 

 

 

 

 

 

 

               

 

 

 

  

7. Repetimos los pasos anteriores, y seleccione el reservorio “Socorro” 

El resultado del filtro debe dar 81 pozos.     

 

Fig. 4.15 Reporte de producción mensual del reservorio Atlanta 
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Ahora utilice el criterio del filtrado por consulta ( Query) 

 
8. Seleccionar Filter > Filter By > Query. 

9. En la ventana Filter By Query hacer click en el botón Edit  

10. Ingresamos monthlyprod.oil > 1000 bbls y a una fecha >=19960601 

11. Click OK dos veces. 

12. EL resultado del filtro muestra dos completaciones. Seleccionar 

Analysis > Report 

 

 

Fig. 4.16 Reporte de producción mensual del reservorio socorro 
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13. En la ventana Edit Report ingresamos las variables seleccionadas 

anteriormente. 

14. Click OK, agrupamos los pozos en el botón Group, y mostramos el 

reporte con el criterio del filtro correspondiente 

 

 

 

 

 

Fig. 4.17 Mapa Base con los dos pozos como resultado del Query 
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4.8 ALTERNATIVAS DE PRESENTACIÓN DE REPORTES DE 

PRODUCCIÓN 

 

En este procedimiento usted agregara información de encabezados y de 

pie de pagina  

 

1. Seleccionar Analysis > Report 

Fig. 4.18 Reporte de producción por consulta 
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2.  Si las variables del proyecto están activada en la ventana Edit Report, 

click en Clear para limpiar el texto, luego ingresamos la función 

@name, y las variables date, Monthlyprod.oil , monthlyprod.gas , 

monthlyprod.water , click OK. 

3. Seleccionar Edit > Report Display desde el menú de barra 

4. Seleccionar la solapa Headers. 

Nota: El sistema de función @Loadname()esta ya seleccionado por 

default 

5. Click Delete. 

6. Click Add. 

El cuadro de diálogo Headers se muestra 

7. Quitamos el sistema de función @Loadname() haciendo click en Clear  

8. Click System Functions 

9. Buscar en el cuadro la función FmtDate. 

10. Doble click en FmtDate para agregarlo al área de datos de entrada. 

11. Buscar la función Today y agréguela al primer argumento del sistema 

de función FmtDate.. 

12. Tipee “mm/dd/yy” como el formato en el espacio para el segundo 

argumento. 

13. Click OK. 

El cuadro de dialogo de la ventana Edit Report Attributes muestra las 

nuevas variables agregadas para generar el reporte. 
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14. Click Add. 

15. Ingrese en el cuadro de texto “Monthly Production Report “ 

16. Click OK. 
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17. Click Add. 

18. Doble click en la variable del proyecto gh.Lease. 

19. Click OK.. 

 

 

 

 

 

 

 

 

 

 

20. Repetimos este procedimiento para la siguientes variable del proyecto: 

• gh. Reservoir 

• gh. Cumoil 

• gh. Cumgas 

• gh. Cumwater 
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21. Click OK. 

22. Click en el botón Next y el reporte se muestra con los Headers 

seleccionados. 

 

Nota: Usted puede guardar el reporte seleccionando Edit > Report 

Display > Headers > Save As desde el menú de barra y guardarlo en 

un archivo con una extensión  *.rh para ser utilizado con algún otro 

reporte. 
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23. Seleccionar Edit > Report Display del menú de barra. 

24. Seleccionar la solapa Footers. 

25. Click Add. 

 

 

 

 

Fig. 4.19 Reporte de producción mensual con encabezados 
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26. Ingresar en el cuadro de texto “ Campo Gustavo Galindo Velasco “. 

27. Click OK  

El Footer es agregado a la lista. 

28. Click en Aceptar. 

El Footer es mostrado en la parte de  abajo de la pagina del reporte. 
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Utilizar Report Sums y Breaks 

 

29. Seleccionar Analysis > Report si las variables anteriores ya están 

activadas click OK, sino ingresamos  la función @name, y las 

variables date, Monthlyprod.oil , monthlyprod.gas , monthlyprod.water , 

click OK 

30. Edit > Report Display desde el menú de barra 

31. Hacer lo siguiente: 

Fig. 4.20 Reporte de producción mensual con pie de pagina 
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Desde la Current Column de la lista desplegable, seleccionar 

Monthlyprod.Oil. 

Desde el Subtotal de la lista desplegable, seleccionar Sum. 

32. Asegúrese que los atributos del reporte estén como sigue: 

Unit : bbl 

System: Current 

Multiplier: 1 

Width: 10 

Decimals: 0 

Justification: Right 
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33. Hacer lo siguiente: 

Desde la Current Column de la lista desplegable, seleccionar 

Monthlyprod.Gas. 

Desde el Subtotal de la lista desplegable, seleccionar Sum 

34. Asegúrese que los atributos restantes del reporte sean como sigue: 

Unit: cf 

System: Current 

Multiplier: M 

Width: 10 

Decimals: 0 

Justification: Right 

35. Hacer lo siguiente:  

Desde la Current Column de la lista desplegable, seleccionar 

Monthlyprod.Water. 

Desde el Subtotal de la lista desplegable, seleccionar Sum.  

36. Asegúrese que los atributos restantes del reporte sean como sigue: 

Unit: bbl 

System: Current 

Multiplier: 1 

Width: 10 

Decimals: 0 

Justification: Right 
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37. Después de persolizar todas las columnas , click en Aceptar. 

Las especificaciones del encabezado son aplicado a el reporte, pero la 

suma no es mostrada todavía . 

Nota: OFM permite diferentes opciones para la ubicación de la Sum. 

Usted necesita elegir la opciòn que usted desee. 

38. Seleccionar Edit > Report Display de el menú de barra para agregar 

Breaks a el reporte. 

El cuadro de dialogo Edit Report Attributes se muestra en la pantalla. 

39. Seleccionar la solapa Breaks. 

 

 

 

 

 

 

 

 

 

 

 

     

40. Seleccionar At End of Report. 
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41. Click en Aceptar. 

El reporte muestra la Sum para cada columna al final del reporte. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

42. Seleccionar Edit > Report Display de el menú de barra. 

43. Seleccionar la solapa Breaks. 

 

Fig. 4.21 Reporte de producción mensual con Breaks y Sum 
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44. Seleccionar At Condition. 

45. Click Edit Condition. 

El cuadro de dialogo Create Condition se muestra en la pantalla. 

46. Click en System Functions. 

47. Doble click en Annually en la lista de funciones 

48. Tipee date entre los paréntesis. 
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49. Click OK. 

El cuadro de dialogo Edit Report Attributes se muestra con la opciòn 

del Breaks  y la condición de sintaxis activado. 

50. Click Aceptar. 

El reporte presenta un total de producción en diciembre de cada año. 
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51. Seleccionar View > Lock Headers del menú de barra 

52. Seleccionar File > Save Format desde el menú de barra. 

53. Guardar como Monthly OGW 

54. Click Save. 

55. Seleccionar File > Close del menú de barra para cerrar la ventana del 

reporte. 

 
 

 

Fig. 4.22 Reporte de producción por año con encabezado 
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CAPITULO 5 

ANALISIS DE CURVA DE DECLINACIÓN 

 

5.1 INTRODUCCION 

 
Las curvas de declinación de la producción se usan ampliamente en el 

área de yacimiento y producción para evaluar cada pozo en forma 

individual, estudiar el comportamiento actual del campo y predecir la 

producción futura. 

 
El software OFM, utiliza dos técnica para pronosticar la futura producción: 

La técnica Empírica y Analítica. 

 
Entre los métodos Empíricos que utiliza OFM encontramos, el método 

Exponencial, Armónico e Hiperbólico, además encontramos el método de 

Fetkovick,y el de Análisis de solución Transciente,que son técnicas 

analíticas. Cuando las estimaciones se basan en técnicas matemáticas o 

graficas para el análisis de las curvas de declinación de la producción 

.Debe recordarse siempre que este análisis se usa solo por facilidad, es 
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decir, es un método que acepta un tratamiento grafico o matemático y no 

se basa en las leyes físicas que gobiernan el flujo de petróleo y gas a 

través de la formación. Estas curvas se pueden trazar para cada pozo en 

particular, un grupo de pozos de un yacimiento o todos los pozos del 

mismo. 

                                      
Las curvas de declinación son muy importante para los ingenieros de 

campo, por que permite tener información rápida y confiable sobre las 

expectativas de la producción para los siguientes meses,e indicando en 

forma grafica cuales son los pozos o grupos de pozos que producen 

menos de lo esperado, de manera que se pueda planear los programa de 

recuperación de la producción  

  
En este capitulo vamos a tratar el método Empírico, mas no la técnica 

analítica que utiliza ofm para predecir la producción y retomar la 

información de predicción para futuros estudios. 

 
5.2  DECLINACIÓN EXPONENCIAL 

 
Se supondrá que se esta considerando solo un pozo, pero el análisis se 

    aplica igualmente a un grupo de pozos como si fuera una unidad. Como  

    la forma lógica de graficar la producción es trazarla contra el tiempo, éste  

    fue el primer método utilizado. Después de un periodo durante el cual se 
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   estabilizó la producción, se encontró que hubo un momento en que el 

pozo no podía sostener su producción y su capacidad fue decayendo 

regularmente 

 

En la figura (5.1) se muestra una curva típica de producción contra el tiempo  

en la cual se ha trazado una curva promedio usando líneas punteadas. 

Evidentemente, si se le puede dar una forma regular(matemática)a la 

parte curva de la línea punteada, será posible extrapolar en el futuro, y así 

predecir la producción del pozo, por ejemplo a 1,2,3,4,5 ó 10 años. Si se 

grafican los datos de la producción contra la producción acumulada de 

petróleo se observa que la parte de la curva que declina se puede 

convertir en una línea recta,la cual es por supuesto fácil de 

extrapolar(figura).Si q es la producción y Q es la producción acumulativa 

la ecuación de esta línea recta es: 

  

 

 

 

 

 

 

                                       

Fig. 5.1 Curva de declinación exponencial 
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     q= mQ+c                         5-1 

Donde m y c son constantes. Si la producción q se mantiene durante un corto 

tiempo dt, la producción acumulativa en este tiempo es q dt; por lo tanto, la 

producción acumulativa es la suma de los productos q dt desde el inicio de la 

producción al día presente(tiempo t).  En términos matemáticos: 

                                                      ∫=
t

qdtQ
0

                                     5-2 

                                                       

                                      q= dQ/dt                                      5-3  

Si se deriva la ecuación (5-1) con respecto al tiempo t, 

 

dq/dt =m dQ/dt 

 

de tal manera que a partir de la ecuación 5-3 

 

dq/dt = mq 

                                      1/q dq/dt = m                              5-4 

En la figura 5.2 se observa que la pendiente de la línea obtenida es 

negativa en el periodo de declinación de la producción y  m puede 

escribirse como –b, donde b es positiva. 
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  Sustituyendo en la ecuación 5-4 queda: 

                                    1/q dq/dt = -b                                  5-5 

 

La constante positiva b se llama relación de la declinación de la 

producción continua o nominal. 

En la ecuación 5-1 

                               q = -bq +c                                       5-6 

 

Si la declinación de la producción comienza cuando la producción 

acumulativa del pozo es QO (figura 5.2) y si la producción estabilizada 

antes de ese tiempo es qo , entonces: 

 

 

Fig. 5.2 Producción Acumulada de petróleo vs producción de petróleo 
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qo = -bQO + c 

 

     Sustituyendo en la ecuación (5-6) y ordenando los términos se obtiene: 
 

                              Q – QO = qo – q /b                            5-7 

 

Es decir: la producción acumulativa durante el periodo de declinación es 

igual a la diferencia entre la producción inicial y la producción actual 

dividida entre la relación de la declinación continua. 

De la ecuación 5-5 

 

dq/q = -b dt 

  

                                  Ln q = - bt + a                             5-8 

 

Donde a es la constante de integración. 

Si el periodo de declinación comienza en el tiempo to (figura 5.1) y si la 

producción estabilizada anterior a ese tiempo es qo, 
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Ln qo = -bto + a 

a = bto + ln qo 

Sustituyendo en la ecuación 5-8 

 

                                                 ln q = ln qo –b(t-to)                             5-9  

 

                                                 q= qo exp {-b(t-to)}                            5-10 

 

La ecuación (5-10) permite encontrar la producción en cualquier 

momento, cuando se conoce la producción inicial qo. Supóngase que , 

para simplificar la declinación de la producción comienza tan pronto como 

el pozo entra en producción , de tal manera que to es cero. La ecuación 

(5-10) se reduce a: 

 

                                               ( ) bt
oqq −= exp  

 

5.3 DECLINACION ARMÓNICA e HIPERBÓLICA 

 
Se ha encontrado en muchos de los campos de producción más antiguos 

que una supuesta declinación exponencial de la producción inicial en la 

vida de un pozo condujo a respuesta conservadoras en cuanto ala vida 

máxima del pozo y a la recuperación acumulativa . Una forma de superar 

este problema es considerar que el ritmo de declinación (d o b) es 
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proporcional a la producción en vez de ser constante, por lo tanto, a 

menor taza de producción será menor el ritmo de declinación. En símbolo 

esta consideración implica reemplazar la ecuación 5-5 

 

                                                1/q dq/dt = -b 

 

por la ecuación 

                                                1/q dq/dt = -ckqk                      5-11                                     

     

Donde c y k son constantes positivas. Las curvas de declinación basadas 

en esta ecuación se conocen como Hiperbólicas, y la constante a = 1/k se 

llama constante hiperbólica integrando la ecuación (5-11) y usando la 

condición inicial. 

   

                                                     q = qo  cuando t = 0 

 

                                                     q-k = kCk t +qo
-k 

 

                                                                                qo
k /qk = kCk qo

k t +1              5-12 
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De la ecuación (5-11) el valor inicial del ritmo de declinación es CKqo
k , 

que puede escribirse como bo . Sustituyendo en la ecuación (5-12) se 

obtiene :  

 

                                                         qo
k /qk = kbot + 1   

    

                                                    q =   qo / (1+kbot)1/k                   5-13 

 

Introduciendo la constante hiperbólica a = 1/ k se tiene la expresión final 

para la producción en el tiempo t , es decir , la ecuación hiperbólica dada 

por :  

 

                                                         q =  qo / (1 + bot/a)a              5-14 

 

El valor  b del ritmo de declinación en el tiempo t se obtiene de las 

ecuaciones 5-11y 5 -12 : 

 

                                                        b = bo / (1 + bot/a)                 5-15 

 

En el caso especial de a = 1 se conoce como Declinación Armónica, de    

la ecuación 5-14 y 5-15 , los resultado para la declinación armónica son:  
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                                               q = qo / 1+bot                  5-16                  

                                                                 

                                               b = bo / 1+bot                  5-17 

de lo que se obtiene: 

                                          q/qo = b/bo 

 

Para obtener la producción acumulada cuando a sea diferente de uno, la 

ecuación 5-14  da: 

 

                                             ∫
⎟
⎠
⎞

⎜
⎝
⎛ +

=
T

a
o

o

a
tb

dtqQ
0 1

                             5-18 

 

                                          ⎥
⎦

⎤
⎢
⎣

⎡
⎟
⎠
⎞

⎜
⎝
⎛ +−⋅

−
=

a
tbqq

ba
aQ o

o
o

11
1

              5-19 

 

Bajo una declinación armónica, la producción acumulativa esta dada por: 

                                                      

                                                   ∫ +
=

t

tb
dtqQ

0 0

0

1
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                                           ( )tb
b
qQ o

o

o += 1ln                         5-20  

de la ecuación 5-16                    ⎟⎟
⎠

⎞
⎜⎜
⎝

⎛
=

q
q

b
qQ o

o

o ln                5-21  

y de la ecuación 5-17                  ⎟
⎠
⎞

⎜
⎝
⎛=

b
b

b
qQ o

o

o ln                5-22 

Finalmente, la ecuación 5-21 puede escribirse en la forma : 

                                                    

                                         Q
q
bqq

o

O
o −= lnln                             5-23 

La ecuación 5-23 es la base para obtener una línea recta al graficar la 

producción de petróleo contra la producción acumulativa en papel 

semilogaritmo, figura 5.3, que es la grafica que se utiliza frecuentemente 

en oficinas de campo, además debe recordarse que la declinación 

armónica es la mas optimista de ellas. 

 
5.4 COMPORTAMIENTO DEL GRAFICO QO VS T PARA TODOS LOS 

POZOS DEL ÁREA TIGRE 

 

En esta sección  se mostrara el grafico de producción mensual de 

petróleo vs el tiempo para cada uno de los pozos del área tigre y definir 

cuales de estos pozos se ajusta al modelo de declinación. 
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1. En el menú de barra Analysis > plot 

2. Seleccionar en el menú de barra Edit > plot 

3. Click Remove All 

4. Click en el cuadro Add Múltiple Curves. 

5. En la ventana Add Múltiple Curves seleccionar en el cuadro de la lista 

  Desplegable la variable Monthlyprod.Oil 

6. Click OK.                   

7. En la pestaña Axes seleccionar tipo de escala lineal 

8. Seleccionar Aceptar 
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Este tipo de grafico no se puede identificar bien el comportamiento de 

producción de los pozos del área tigre. Para solucionar este problema se 

puede hacer un filtro y mostrar el grafico de qo vs t por grupos de pozos. 

 

9. En el menú de barra seleccionar Filter > Filter by > Completation 

10. Seleccionar las siguientes completaciones 

 

 

Fig. 5.3 Grafico de historia de producción. 
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• ANC_0580:AT 

• ANC_0793:AT 

• TIG_0001:AT 

• TIG_0004S:SO 

• TIG_0007:PB 

• TIG_0010:AT 

• TIG_0014:AT 

• TIG_0011:PB 

11. Seleccionar Analysis > plot 

12. En el menú de barra Edit > Clear All 

13. Seleccionar Edit > Plot 

14. Click en el cuadro Remove All 

15. Click en el cuadro Add Múltiple Curves  

16.En la ventana Add Múltiple Curves seleccionar la variable 

monthlyprod.Oil 

17. Click OK. 

18. Click en la pestaña Curves, seleccionar el color para cada uno de los  

      pozos 

19. En la pestaña Axes asegúrese que el tipo de escala sea lineal 

20. Seleccionar Aceptar 
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Obsérvese que los pozos TIG_0010:AT, y  TIG_0011:PB tienen un 

comportamiento de declinación. 

Ahora hacer lo mismo para otros grupos de completaciones e ir clasificando 

los pozos que se ajustan al modelo de declinación   

 

 

 

 

Fig. 5.4 Producción mensual de petróleo para 8 pozos 
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5.5 DETERMINACION DE LOS POZOS QUE MEJOR SE AJUSTA A ESTE 

ANÁLISIS DE DECLINACIÓN 

 

En el capitulo anterior se analizó el comportamiento del grafico qo vs t para 

todos los pozos del àrea tigre, y se observo que la mayoría de los pozos 

no tienen un comportamiento normal de declinación, es muy irregular su 

producción, por lo tanto no se podría realizar un análisis de declinación. 

Los pozos que mejor se ajusta a el criterio de declinación son los 

siguientes: 

  

• TIG_0007:PB 

• TIG_0008S:SO 

• TIG_0010:AT 

• TIG_0011:PB 

• TIG_0013:AT 

• TIG_0013S:SO 

• TIG_0014:PB 

• TIG_0023:PB 

• TIG_0028:AT 

• TIG_0043S:SO 

• TIG_0044S:SO 
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• TIG_0048S:SO 

• TIG_0051:PB 

• TIG_0058:AT 

• TIG_0060:AT 

• TIG_0064:AT 

• TIG_1001:ST 

• TIG_1002:ST 

• TIG_1004:ST 

Todos estos pozos servirán de ejemplos para los próximos tópicos a tratar 

en este capitulo de Análisis de Curva de Declinación(DCA). 

 

5.6 CREACIÓN DEL ANÁLISIS DE PREDICCIÓN 

 
Las curvas que rigen el comportamiento de un yacimiento, tales como las 

curvas de presión de fondo, producción de petróleo, acumulado de 

petróleo, relación gas petróleo, relación agua petróleo, números de pozos 

productores, todas están graficadas en función del tiempo 

Son de gran ayuda para los ingenieros de producción y además con el 

análisis de ingeniería de yacimiento, nos permite hacer predicciones del 

comportamiento  a futuro de la producción del campo 
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Una vez analizado la información del yacimiento y el comportamiento 

histórico de producción de los pozos del área Tigre tratados en la sección 

anterior, definimos el tipo de técnica que utiliza OFM para analizar la 

producción a futuro .El método a utilizar se llama “Método Empírico” 

 

5.7 DETERMINACIÓN DE UN ESCENARIO PARA LA PREDICCIÓN 

 

El método empírico esta basado usualmente sobre la historia de 

producción de los pozos, no seria lo correcto predecir la producción de un 

pozo que no ha producido por un largo tiempo 

2. Seleccionar Filter >Filter By>Completion 

3. En la ventana Filter by Completion, seleccionar los pozos a los cuales  

se le va hacer el análisis , ejm: 

a. TIG_1004: ST 

b. TIG_1002: ST 

c. TIG_0040: AT 
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4. Click OK para retornar al mapa base  

  

5. Seleccionar Análisis >Forecast ( también se puede entrar a Forecast 

haciendo click en el botón de la barra de herramienta) 

6. Seleccionar Edit > Scenario (ó click derecho sobre el Mouse>Scenario) 

7. En la ventana Case 1-Scenario, seleccionamos Oil para la lista de fases 

8. Para esta fase(Oil), la variable Time(Date)es Date.  

9. La variable Oil Rate es Monthlyprod.Oil 

10. Click OK y un grafico se desplaza. 
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11. Seleccionar Edit > Default Scenario. 

12. En la ventana Default Scenario, click en el  Historical Regression, esto 

se centrara en la fase petróleo y el uso del método Empírico  

13. En la sección Decline Rate, activar Monthly Eff. 

14. Dejar el limite no especificado 

15. Elegir Best Method de el cuadro Method 

Fig. 5.5  Mapa base con los tres pozos seleccionados 
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 Nota: Con esta opción, nosotros les respondemos a OFM para que use 

el mejor método posible que puede ser aplicado a sus datos. Las otras 

opciones son:   Exponencial, Hiperbólico, y Armónico 
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16. No especificar el b-value Limits. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

17. Click en el cuadro de Forecast. 

18. Usted omite para el schedule 1 

a. Starting Time - Months from End, empieza el mes desde uno(1) 

b. Starting Rate - From Historical Fit 

c. Ending Time – Months From Start , fijar para 120 meses (10años) 
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d. Reserve Type – Proven – Developed 

e. Chequear Economic Limit 

f. Verifique Decline Type, fijamos Historical Regression. 

19. Click sobre Apply to Current Scenario  
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20.  Seleccionar Edit > Graph ( ó doble click sobre el gráfico) 

21. En la ventana DCA Graphs, modifique las opciones si es conveniente 

22. Click sobre la opción Curves, activar todos los Campos sobre la curva 

23. Click en la caja Legend. Sobre el grupo Display List, chequear todos 

los parámetros que se desee mostrar en la Legend  

24. Si  se quiere mostrar un encabezado sobre el gráfico de predicción, 

click en la opción 

Headers 

25. Click Add 

26. Click Assist e ingresar “Forecast entity” 

27. Click Ok. El gráfico se desplaza sobre la pantalla  

 

        

 

 

 

 

 

 

 

 

 

Fig. 5.6 Análisis  de predicción para el pozo TIG_0013S:SO 
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Nota: 
 Para mover un encabezado, usar el botón izquierdo del mouse en una 

operación 

“drag y drop” 

 Se puede agregar / borrar un encabezado haciendo click derecho 

sobre el encabezado y Seleccionar la opción desired  

 usted puede salir de la definición de el encabezado haciendo click 

derecho sobre el mouse y seleccionar Edit 

 Para mover ó cambiar el tamaño del gráfico, click derecho sobre el 

gráfico y seleccionar Graph Move / Resize. 

 Para mover Legend , seleccionamos Legend Move haciendo click 

derecho  
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5.8 USO DE LAS DIFERENTES CARACTERISTICAS DEL ANÁLISIS DE 

PREDICCIÓN 

1. Sobre la barra de herramienta click en el botón Next. El pozo 

TIG_0011:PB se  desplaza 

 

 

 

 

 

 

 

 

 

 

        

 

 

2. Seleccionar Edit > Scenario, click en la pestaña Forecast y 

seleccionar Last Historical Rate desde la lista Starting Rate.  

3. Click OK. Guardar la predicción ( desde File > Save ó usando el botón 

Save) 

Y el gráfico se muestra como sigue. 
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4.  

 

 

 

 

 

 

 

 

 

5. Click en el botón Next. La predicción para el pozo TIG_0013S: SO se 

desplaza 

6. Seleccionar  Edit > Scenario. 

7. Click sobre la pestaña Forecast , y seleccionar Last Historical Date 

de la lista Starting Time.  

8. Click OK. Guardar la predicción , el gráfico se desplaza  

 

9. Click en el botón Next. El trabajo de predicción para el pozo 

TIG_0064: AT el gráfico se muestra  

Fig. 5.7 Análisis  de predicción para el pozo TIG_0011:PB 
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10. Seleccionar Edit > Scenario . 

11. Click sobre la pestaña Historical Regression 

12. Seleccionar la opción Hiperbolic en el cuadro Method 

13. Ingresar un valor para la constante b, sino OFM podría seleccionar el 

mejor valor para b al usar la regresión Hiperbolic 

14. Click sobre la pestaña Forecast. 

15. Seleccionar desde From Fit de la lista Starting Rate.  

16. Click OK. Guardar la predicción y el gráfico se muestra. 

 

 

 

Fig. 5.8 Análisis  de predicción para el pozo TIG_0064:AT 
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17. Click en el botón Next. La predicción para el pozo TIG_1001:ST el 

gráfico se muestra  

18. Seleccionar Edit > Scenario 

19. Click sobre la pestaña Forecast. 

20. Seleccionar Last Historical Date para el Starting Time 

21. Seleccionar  From Fit de la Starting Rate. 

22. En el cuadro Decline Type, seleccionar Exponential. 

23. Ingresar un valor de 0.01 para la Decline Rate.  

24. Click OK Save la predicción y podría mostrarse como sigue  

 

 

 

 

 

 

 

  

 

 

 

 

       

Fig. 5.9 Análisis  de predicción para el pozo TIG_1001:ST 
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5.9 GENERACIÒN DE REPORTES Y GRÁFICOS DE LOS RESULTADOS 

DE LA PREDICCIÒN 

 

Antes de mostrar los resultados del Análisis de Curva de 

Declinación(DCA) en gráficos y reportes, se tiene que crear las variables 

calculadas necesarias para la predicción, estas variables son: 

 

FCST.OilonGroup = @Forecast ( date.”oil”,” Case1”, “Group”), sirve para 

almacenar la predicción de la taza de petróleo sobre un grupo de pozos 

 

FCST.GroupofOil = @Forecast( date, “oil”, “Case1”,”Sum”),esta variable 

calculada nos permite agregar predicción de producción de petróleo 

individual, como también para un grupo de pozo 

 

FCST.RemRes = @DcaResults(“oil RES”, “Case1”,1), calcula las 

reservas remanentes de petróleo para la selección completa de pozos ò 

grupos de pozos, basado sobre un caso especifico 

 

FCST.EUR = @DcaResults(“oilEUR”,”Case1”,1), muestra los resultado 

de las ultimas reservas recuperables para un caso específico. 
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1. Seleccionar Edit > Proyect > Calculated Variables, del menú de 

barra  

2. Asegúrese que el Prefix este seleccionado 

3. Editar la variable FCST. OilonGroup 

4. Click Add. 
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5. En el cuadro Edit Calculated Variable, ingresar el sistema de función  

@Forecast(date,”oil”,” Case1”,”group”) 

6. Click OK 

 

                           

7. Asignar unidades a la variable 

8. Aceptar 
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9. Para generar las variables FCST.GroupofOil, FCST.RemRes, y 

FCST.EUR repetimos los pasos anteriores del  1 – 8 para cada 

variable. 

Utilizar estas variables calculada para generar reportes y gráficos: 

1. Seleccionamos Filter > Filter By > Completation , ingresar los pozos 

a los cuales se le va hacer el Análisis De Declinación 

2. Click OK 
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3. Seleccionar Análisis > Forecast  

4. Seleccionar Edit > Scenario 

5. En la ventana Case1 – Scenario ,  Click en la pestaña Forecast 

6. Asignar lo siguiente: 

a. Starting Time - Months from End, empieza el mes desde uno(1) 

b. Starting Rate - From Historical  

c. Ending Time – Months From Start , fijar para 120 meses (10años) 

d. Reserve Type – None 

e. Verifique Decline Type, seleccionar la opciòn Historical 

Regression. 

7. Aceptar 
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8. Seleccionar Analysis > Report para abrir una ventana report 
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9. Seleccionar Edit > Report Parameters  e ingresar : 

@name(),date,monthlyprod.oil  fcst.RemRes ,Fcst.EUR , y fcst.OilRate 

 

  

10. Click OK 
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Ahora los resultados de predicción mostrados en reportes pueden ser 

generado en forma grafica 

 

 

 

Fig. 5.10 Resultados de predicción mostrados en reportes 
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11. Seleccionar Analysis > Plot 

12. Edit > Plot , En el eje X seleccionar Date, en el eje Y la variable 

FCST.OilRate  

 

              

13. Click en la pestaña Curve, le damos los atributos a cada una de las 

curvas 

14. En la pestaña Axes, seleccionar el tipo de escala para el eje X y Y 

15. Aceptar.  
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Fig. 5.11 Resultados de predicción mostrados en gráficos 
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CONCLUSIONES Y RECOMENDACIONES 

 

CONCLUSIONES 
 
 

• Los resultados producidos por el proyecto podrían mejorar y controlar 

la producción del campo. 

• La rata de producción como producto de la predicción se ajustan a la 

realidad. 

• Este proyecto de investigación se puede aplicar a todo el campo 

Gustavo Galindo Velasco. 

• Con la utilización de OFM ayuda a los ingenieros a manejar más 

pozos de una manera efectiva y en menor tiempo. 

• Los valores de producción a futuro producto del análisis de predicción 

ayudarían a tomar correctivos para retomar los niveles óptimos de 

producción. 
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RECOMENDACIONES 

 
• Ampliar la base de datos con informacion de registros eléctricos, 

pruebas de presión, reacondicionamiento de pozos y ubicación de 

fallas. Para obtener informacion mas completa del campo. 

 

• En la utilización de software OFM se debe crear un proyecto que 

contenga dos carpetas, una para los datos y otra para el proyecto con 

la finalidad de acceder a los datos y actualizarlos. De tal manera que 

se pueda en lo posterior manejar, analizar e interpretar los datos. 

 

• Implementar una base de datos para registrar la producción de Gas.  
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